FORUM DE DISCUSSION SUR LE LANGAGE PANORAMIC

Développement d'applications avec le langage Panoramic
 
AccueilAccueil  FAQFAQ  RechercherRechercher  S'enregistrerS'enregistrer  MembresMembres  GroupesGroupes  Connexion  
Derniers sujets
» Exemple d'une nouvelle version d'un GRID
par Minibug Mer 16 Jan 2019 - 18:23

» Peut-être un bug de l'éditeur pour Jack
par jjn4 Lun 14 Jan 2019 - 17:45

» Wordpic.2
par jjn4 Sam 12 Jan 2019 - 16:34

» Fichier <-> Datas
par jjn4 Sam 12 Jan 2019 - 16:23

» Version instantanée V 0.9.29i6 du 08/01/2019
par Jack Mer 9 Jan 2019 - 7:50

» Make_Exe avec la version V 0.9.29i6
par Jack Mar 8 Jan 2019 - 20:14

» caret_yb_position
par jjn4 Mar 8 Jan 2019 - 19:34

» Problème avec l'analyseur syntaxique de Panoramic.
par jjn4 Lun 7 Jan 2019 - 14:44

» PanExpress : l'éditeur Panoramic avec création d'objet
par Minibug Dim 6 Jan 2019 - 18:39

» Bonne année 2019
par silverman Sam 5 Jan 2019 - 12:02

» Blocage Editeur
par Minibug Mar 1 Jan 2019 - 15:54

» Un texte clignotant
par JL35 Mar 1 Jan 2019 - 13:50

» Bonnes fêtes de fin d'année !
par JL35 Mar 1 Jan 2019 - 0:04

» ON_CLICK sur HVIEWER
par JL35 Lun 31 Déc 2018 - 16:56

» Logiciel de soutien scolaire.
par Pedro Alvarez Lun 31 Déc 2018 - 7:51

Navigation
 Portail
 Index
 Membres
 Profil
 FAQ
 Rechercher
Rechercher
 
 

Résultats par :
 
Rechercher Recherche avancée
Janvier 2019
LunMarMerJeuVenSamDim
 123456
78910111213
14151617181920
21222324252627
28293031   
CalendrierCalendrier

Partagez | 
 

 Problème avec 'file_load'.

Aller en bas 
AuteurMessage
Pedro Alvarez

avatar

Nombre de messages : 1232
Date d'inscription : 19/01/2014

MessageSujet: Problème avec 'file_load'.   Dim 17 Juin 2018 - 15:05

Bonjour.

Je ne comprends pas pourquoi le sprite n'est pas affiché !

Il semble que le problème vienne de file_save 7, qui ne sauvegarde pas l'image du sprite.

Par contre, si je remplace file_save 7 par snapshot 7, tout fonctionne correctement.


Code:
dim fi$:fi$="fond.bmp"        

maximize 0

picture 1
full_space 1  

create_hide
scene2d 7:top 7,top(1):left 7,left(1):width 7,width(1):height 7,height(1)
file_save 1,fi$:file_load 7,fi$
create_show                          
sprite 1:sprite_file_load 1,"symboles\soleil.bmp"

sprite_position 1,400,400

' Sauvegarde, puis suppression du scene2d.
file_save 7,fi$:delete 7
' Rechargement du picture avec l'image modifiée.
file_load 1,fi$
Revenir en haut Aller en bas
Voir le profil de l'utilisateur
JL35



Nombre de messages : 6422
Localisation : 77
Date d'inscription : 29/11/2007

MessageSujet: Re: Problème avec 'file_load'.   Dim 17 Juin 2018 - 19:31

Dans le cas d'un SCENE2D:
FILE_LOAD N,F charge le SCENE2D avec l'image du fichier format bmp.
FILE_SAVE N,F sauvegarde l'image de fond du SCENE2D
SNAPSHOT N,F sauvegarde l'ensemble image de fond + les sprites superposés à cette image
Revenir en haut Aller en bas
Voir le profil de l'utilisateur
Pedro Alvarez

avatar

Nombre de messages : 1232
Date d'inscription : 19/01/2014

MessageSujet: Problème avec 'file_load'.   Lun 18 Juin 2018 - 8:12

Bonjour.

Merci JL35 pour ces explications.
Revenir en haut Aller en bas
Voir le profil de l'utilisateur
Contenu sponsorisé




MessageSujet: Re: Problème avec 'file_load'.   

Revenir en haut Aller en bas
 
Problème avec 'file_load'.
Revenir en haut 
Page 1 sur 1
 Sujets similaires
-
» problème avec l'enregistreur numérique
» [résolu] Problème avec Glary utilities
» Problème avec l'explorateur Windows (Résolu)
» [LAG II ph1] Problème avec la pédale embrayage
» [Résolu] Problème avec psg tv

Permission de ce forum:Vous ne pouvez pas répondre aux sujets dans ce forum
FORUM DE DISCUSSION SUR LE LANGAGE PANORAMIC :: PANORAMIC :: A l'aide!-
Sauter vers: