FORUM DE DISCUSSION SUR LE LANGAGE PANORAMIC

Développement d'applications avec le langage Panoramic
 
AccueilAccueil  FAQFAQ  RechercherRechercher  S'enregistrerS'enregistrer  MembresMembres  GroupesGroupes  Connexion  
Derniers sujets
» Planétarium virtuel.
par Jean Claude Aujourd'hui à 18:16

» 11 (en analyse): commandes sur TAB et SUB_MENU.
par Jack Aujourd'hui à 14:10

» 10 (en analyse): Erreur sur variable locale.
par Jack Aujourd'hui à 14:05

» Métamatière, éternité et renouvellement
par Oscaribout Aujourd'hui à 12:40

» De retour...
par Yannick Hier à 15:11

» bug SEVERE fnc+sub : (35)name already defined
par Oscaribout Dim 12 Aoû 2018 - 23:55

» ajouter des blancs dans un TXT
par silverman Dim 12 Aoû 2018 - 15:38

» Encadrement
par Jean Claude Dim 12 Aoû 2018 - 11:53

» Des rectangles...
par JL35 Dim 12 Aoû 2018 - 10:53

» TRIGGER_KEY_COMBINED_TOUCH
par Jean Claude Mar 7 Aoû 2018 - 20:58

» ITEM_SELECT N,L pour synedit
par Jean Claude Mar 7 Aoû 2018 - 19:11

» amélioration panoramic
par silverman Dim 5 Aoû 2018 - 18:34

» Commande file_readln.
par Pedro Alvarez Dim 5 Aoû 2018 - 17:08

» Klaus ?
par Jack Sam 4 Aoû 2018 - 22:48

» Défragmentation du disque dur
par JL35 Sam 4 Aoû 2018 - 21:06

Navigation
 Portail
 Index
 Membres
 Profil
 FAQ
 Rechercher
Rechercher
 
 

Résultats par :
 
Rechercher Recherche avancée
Août 2018
LunMarMerJeuVenSamDim
  12345
6789101112
13141516171819
20212223242526
2728293031  
CalendrierCalendrier

Partagez | 
 

 File_move (résolu, je crois)

Aller en bas 
AuteurMessage
jjn4

avatar

Nombre de messages : 1761
Date d'inscription : 13/09/2009

MessageSujet: File_move (résolu, je crois)   Sam 26 Aoû 2017 - 17:56

Un petit bonjour des vacances...
(mais je n'ai pu m'empêcher de faire
un peu de panoramic, aïe, aïe, aïe)

La question que je pose est celle-ci :
Est-il normal que si je fais :
Code:
file_move "D:\noel.bmp","D:\Temp\noel.bmp"
ça marche, ça déplace la photo
Et si je fais :
Code:
file_move "C:\noel.bmp","C:\Temp\noel.bmp"
ça ne marche pas ?
File_move serait-il allergique à la lettre C ?
(alors qu'avec File_copy, ça marche)
(on dirait bien que j'ai débusqué un bug)
scratch alien scratch
(qu'en dit le forum (très en vacances ces temps-ci...?))
(à bientôt... enfin, pas tout de suite!)
sunny alien sunny
Revenir en haut Aller en bas
Voir le profil de l'utilisateur http://jjn4.e-monsite.com
jjn4

avatar

Nombre de messages : 1761
Date d'inscription : 13/09/2009

MessageSujet: Re: File_move (résolu, je crois)   Sam 26 Aoû 2017 - 18:42

Oups, je crois bien que j'ai trouvé ce qui ne va pas
et que le mot-clé File_move n'a pas de bug.
Ca pourrait être dû à cette saloperie de sécurité
de l'ordinateur, mais pas simple, quand même
parce que ça peut le faire aussi avec des sous-répertoires...
scratch alien scratch


Dernière édition par jjn4 le Dim 27 Aoû 2017 - 15:16, édité 1 fois
Revenir en haut Aller en bas
Voir le profil de l'utilisateur http://jjn4.e-monsite.com
JL35



Nombre de messages : 6311
Localisation : 77
Date d'inscription : 29/11/2007

MessageSujet: Re: File_move (résolu, je crois)   Sam 26 Aoû 2017 - 19:52

Salut jj,

C'est curieux ton affaire, chez moi ça marche très bien (transfert d'un fichier txt de C:\ vers C:\TEMP).
  file_move "C:\rapport.txt","C:\Temp\rapport.txt"
Le fichier est bien déplacé.

Par contre, ce qui est curieux, si je recommence (le fichier émetteur n'existe plus), eh bien je n'ai pas d'erreur !
Et même plus:
   file_move "K:\Bidule","C:\Temp\rapport.txt"
évidemment il ne se passe rien, mais pas d'erreur non plus... scratch
Revenir en haut Aller en bas
Voir le profil de l'utilisateur
jjn4

avatar

Nombre de messages : 1761
Date d'inscription : 13/09/2009

MessageSujet: Re: File_move (résolu, je crois)   Dim 27 Aoû 2017 - 15:15

Salut JL35 :
JL25 a écrit:
C'est curieux ton affaire...
C'est sur un W10 dernier cri hyper sécurisé qui fait des tas de difficultés
lorsqu'on veut ajouter un fichier en C: ou en effacer un. Ca doit être pour ça.

JL35 a écrit:
mais pas d'erreur non plus...
Apparemment, il accepte tout type d'anomalie
sauf que le fichier à déplacer soit déjà présent à l'adresse de destination.
A+
sunny elephant alien flower afro
Revenir en haut Aller en bas
Voir le profil de l'utilisateur http://jjn4.e-monsite.com
JL35



Nombre de messages : 6311
Localisation : 77
Date d'inscription : 29/11/2007

MessageSujet: Re: File_move (résolu, je crois)   Dim 27 Aoû 2017 - 20:35

Bonsoir jj,
C'est probable qu'il y a un problème de protection à la racine du disque, surtout avec W10 (je suis toujours sous 7, j'attends d'être forcé de basculer...).
Mais ce n'est pas très normal qu'il n'y ait pas d'erreur signalée par Panoramic si on demande à déplacer un fichier qui n'existe pas !
L'erreur est pourtant prévue dans la doc de la fonction FILE_MOVE F1,F2, erreur si:
- le fichier F1 n'existe pas
- le fichier F2 existe déjà
- F1 ou F2 n'est pas un nom correct de fichier.
Revenir en haut Aller en bas
Voir le profil de l'utilisateur
Contenu sponsorisé




MessageSujet: Re: File_move (résolu, je crois)   

Revenir en haut Aller en bas
 
File_move (résolu, je crois)
Revenir en haut 
Page 1 sur 1
 Sujets similaires
-
» [résolu]pc infecté par wwwzuc32.exe
» [ résolu ]à propos de TFC
» Optimisation sécurité PC [Résolu]
» [Résolu] Fenêtres publicitaires intempestives
» [résolu]EXCEL

Permission de ce forum:Vous ne pouvez pas répondre aux sujets dans ce forum
FORUM DE DISCUSSION SUR LE LANGAGE PANORAMIC :: PANORAMIC :: Un bug dans PANORAMIC?-
Sauter vers: